summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorPedro Alves <palves@redhat.com>2013-04-19 18:32:54 +0000
committerPedro Alves <palves@redhat.com>2013-04-19 18:32:54 +0000
commitbd3f3b553570d7a09cd16545c3d842d70bf3b7da (patch)
treea9f1090f4eb3c32a4823e664d9bd00f1a27e24c3 /gdb/configure.ac
parent8bf54274eced4d6b47ba1296f20cc7d5f737e673 (diff)
downloadbinutils-gdb-bd3f3b553570d7a09cd16545c3d842d70bf3b7da.tar.gz
Enable -Wpointer-sign by default.
This enables -Wpointer-sign by default. I've checked that --enable-targets=all builds fine with the following as --host, on x86_64 Fedora 17 --build: x86_64 GNU/Linux i386 GNU/Linux i386 MinGW-w64 i386 msdos/djgpp OK? gdb/ 2013-04-19 Pedro Alves <palves@redhat.com> * configure.ac (build_warnings): Replace -Wno-pointer-sign with -Wpointer-sign. * configure: Regenerate. gdb/doc 2013-04-19 Pedro Alves <palves@redhat.com> * gdbint.texinfo (Misc Guidelines) <Compiler Warnings>: Replace -Wno-pointer-sign text with text on -Wpointer-sign.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index ce6fa7a8a7e..884b40ebb19 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1925,7 +1925,7 @@ fi
# NOTE: If you change this list, remember to update
# gdb/doc/gdbint.texinfo.
build_warnings="-Wall -Wdeclaration-after-statement -Wpointer-arith \
--Wformat-nonliteral -Wno-pointer-sign \
+-Wformat-nonliteral -Wpointer-sign \
-Wno-unused -Wunused-value -Wunused-function \
-Wno-switch -Wno-char-subscripts -Wmissing-prototypes \
-Wdeclaration-after-statement -Wempty-body"