summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2013-05-17 16:24:21 +0000
committerH.J. Lu <hjl.tools@gmail.com>2013-05-17 16:24:21 +0000
commita48b32c06849c3e91e92cb5261e135a55cd584c4 (patch)
treeb77cf1866cca3f37c2f5fd4c49d541d7b26a9f90 /gdb/configure.ac
parent4934fdafeae14d61c01107ecaee2f7fac6ff12cb (diff)
downloadbinutils-gdb-a48b32c06849c3e91e92cb5261e135a55cd584c4.tar.gz
Replace hardcoded -ldl with check for availability
2013-05-17 Pavel Chupin <pavel.v.chupin@intel.com> * acinclude.m4: Add check for dlopen in libdl. * configure.ac: Ditto. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index c3f79ec1b40..5fcec522d37 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -2036,7 +2036,7 @@ if test $gdb_cv_var_elf = yes; then
[Define if ELF support should be included.])
# -ldl is provided by bfd/Makfile.am (LIBDL) <PLUGINS>.
if test "$plugins" = "yes"; then
- LIBS="-ldl $LIBS"
+ AC_SEARCH_LIBS(dlopen, dl)
fi
fi