summaryrefslogtreecommitdiff
path: root/gas/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2015-10-20 08:58:10 -0700
committerH.J. Lu <hjl.tools@gmail.com>2015-10-20 08:58:25 -0700
commitedeefb679201858453502e21446d7a65fedeaf0e (patch)
tree831715c94240ed23f012aa9372f3f24dab4c2087 /gas/configure.ac
parentf9c62303d87da9c766ca67d01f602130c2777951 (diff)
downloadbinutils-gdb-edeefb679201858453502e21446d7a65fedeaf0e.tar.gz
Add --enable-compressed-debug-sections={all,gas,gold,ld}
This patch removes the gas configure option: --enable-compressed-debug-sections and adds a toplevel configure option: --enable-compressed-debug-sections={all,gas,gold,ld} to enable compressed debug sections for gas, gold or ld by default. At the moment, this configure option is ignored by gold and ld. For x86 Linux targets, default to compressing debug sections in gas. PR gas/19109 * configure.ac: Add --enable-compressed-debug-sections={all,gas,gold,ld}. * configure: Regenerated. gas/ PR gas/19109 * NEWS: Update --enable-compressed-debug-sections=. * configure.ac: Remove --enable-compressed-debug-sections. (DEFAULT_FLAG_COMPRESS_DEBUG): Check --enable-compressed-debug-sections={all,gas} instead of --enable-compressed-debug-sections. For x86 Linux targets, default to compressing debug sections. * configure: Regenerated.
Diffstat (limited to 'gas/configure.ac')
-rw-r--r--gas/configure.ac23
1 files changed, 8 insertions, 15 deletions
diff --git a/gas/configure.ac b/gas/configure.ac
index 278b45d9b89..b15da9a9c25 100644
--- a/gas/configure.ac
+++ b/gas/configure.ac
@@ -64,18 +64,6 @@ if test x$ac_checking != x ; then
AC_DEFINE(ENABLE_CHECKING, 1, [Define if you want run-time sanity checks.])
fi
-# PR gas/19109
-# Decide the default method for compressing debug sections.
-ac_default_compressed_debug_sections=unset
-# Provide a configure time option to override our default.
-AC_ARG_ENABLE(compressed_debug_sections,
-[ --enable-compressed-debug-sections compress debug sections by default],
-[case "${enableval}" in
- yes) ac_default_compressed_debug_sections=yes ;;
- no) ac_default_compressed_debug_sections=no ;;
- *) ac_default_compressed_debug_sections=unset ;;
-esac])dnl
-
using_cgen=no
AM_BINUTILS_WARNINGS
@@ -548,9 +536,14 @@ changequote([,])dnl
done
-if test x$ac_default_compressed_debug_sections == xyes ; then
- AC_DEFINE(DEFAULT_FLAG_COMPRESS_DEBUG, 1, [Define if you want compressed debug sections by default.])
-fi
+# For x86 Linux targets, default to compressing debug sections unless
+# configured otherwise.
+case x${enable_compressed_debug_sections}-${target_cpu_type}-${target_os} in
+x*gas*|xall*|x-i386-linux-gnu)
+ AC_DEFINE(DEFAULT_FLAG_COMPRESS_DEBUG, 1,
+ [Define if you want compressed debug sections by default.])
+ ;;
+esac
# Turn on all targets if possible
if test ${all_targets} = "yes"; then