summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Sandiford <rdsandiford@googlemail.com>2007-12-18 07:37:34 +0000
committerRichard Sandiford <rdsandiford@googlemail.com>2007-12-18 07:37:34 +0000
commit57c53b2bffdcc0cbfe69ce4f8fca343fa7f3be34 (patch)
tree81249f01a32fe0d88ed1e5d2ab6e1e213d3251c7 /configure.ac
parentfee14b60754f80199571f48e7772c5cbbaf442c7 (diff)
downloadbinutils-gdb-57c53b2bffdcc0cbfe69ce4f8fca343fa7f3be34.tar.gz
/tmp/foo.diff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 63b9c933235..e6c8eb045c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1220,11 +1220,11 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
if test x"$have_gmp" = xyes; then
saved_LIBS="$LIBS"
LIBS="$LIBS $gmplibs"
- dnl MPFR 2.2.0 is acceptable but buggy, MPFR 2.2.1 is better.
+ dnl MPFR 2.2.1 is acceptable, but MPFR 2.3.0 is better.
AC_MSG_CHECKING([for correct version of mpfr.h])
AC_TRY_LINK([#include <gmp.h>
#include <mpfr.h>],[
- #if MPFR_VERSION < MPFR_VERSION_NUM(2,2,0)
+ #if MPFR_VERSION < MPFR_VERSION_NUM(2,2,1)
choke me
#endif
mpfr_t n;
@@ -1237,7 +1237,7 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
mpfr_subnormalize (x, t, GMP_RNDN);
], [AC_TRY_LINK([#include <gmp.h>
#include <mpfr.h>],[
- #if MPFR_VERSION < MPFR_VERSION_NUM(2,2,1)
+ #if MPFR_VERSION < MPFR_VERSION_NUM(2,3,0)
choke me
#endif
mpfr_t n; mpfr_init(n);
@@ -1248,7 +1248,7 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
CFLAGS="$saved_CFLAGS"
if test x$have_gmp != xyes; then
- AC_MSG_ERROR([Building GCC requires GMP 4.1+ and MPFR 2.2.1+.
+ AC_MSG_ERROR([Building GCC requires GMP 4.1+ and MPFR 2.3.0+.
Try the --with-gmp and/or --with-mpfr options to specify their locations.
Copies of these libraries' source code can be found at their respective
hosting sites as well as at ftp://gcc.gnu.org/pub/gcc/infrastructure/.