summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-08-19 22:21:10 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-08-19 22:21:10 +0000
commit34a0f3cffad19d24b3d36be9a39d69ae353889da (patch)
tree47a83ac68e7a7c1805198856f1e7c2d5e6629cfb /configure.ac
parentc1102ce79aa237e26045e2a32867c79702cd5ad0 (diff)
downloadbinutils-gdb-34a0f3cffad19d24b3d36be9a39d69ae353889da.tar.gz
Disable option checking in the toplevel, avoid 2.64 fopen glitch.
/: * configure.ac: Call AC_DISABLE_OPTION_CHECKING. (baseargs): Add --disable-option-checking. * configure: Regenerate. config/: * override.m4 (AC_DISABLE_OPTION_CHECKING): Define to be empty if not defined, to avoid error with 2.59. (_AC_LANG_IO_PROGRAM): When the Autoconf version is exactly 2.64, avoid per-language instances to drop fopen from test program.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7508758f01f..9da0048969a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,7 @@ m4_include(config/proginstall.m4)
AC_INIT(move-if-change)
AC_PREREQ(2.59)
+AC_DISABLE_OPTION_CHECKING
progname=$0
# if PWD already has a value, it is probably wrong.
@@ -2662,6 +2663,7 @@ baseargs="$baseargs --program-transform-name='${gcc_transform_name}'"
if test "$silent" = yes; then
baseargs="$baseargs --silent"
fi
+baseargs="$baseargs --disable-option-checking"
# For the build-side libraries, we just need to pretend we're native,
# and not use the same cache file. Multilibs are neither needed nor