summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-07-05 20:24:00 +0545
committerMike Frysinger <vapier@gentoo.org>2017-03-03 11:03:25 -0700
commit561d984aa3a3b99bbd9c6ddf6ba08dadd107d62c (patch)
treee019b4acb329cf7b362293b9c5acd4a163942c92
parentbb4bd6b89365800a7b403ce505401d0c02ad02f8 (diff)
downloadbinutils-gdb-users/gentoo/2.28.tar.gz
opcodes: link against libbfd.la for rpath depsusers/gentoo/2.28
The reason opcodes doesn't link against libbfd.la is to workaround a libtool bug where it uses installed -L paths ahead of DESTDIR paths. The downside is that the library itself lacks rpath tags to find the right version of libbfd.so. Since Gentoo has patched the libtool bug for a while, we don't need the workaround. Use the .la file so we get the rpath tags. URL: https://bugs.gentoo.org/563934
-rwxr-xr-xopcodes/configure2
-rw-r--r--opcodes/configure.ac2
2 files changed, 2 insertions, 2 deletions
diff --git a/opcodes/configure b/opcodes/configure
index be87eb22a5f..19528bef690 100755
--- a/opcodes/configure
+++ b/opcodes/configure
@@ -12561,7 +12561,7 @@ if test "$enable_shared" = "yes"; then
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"
diff --git a/opcodes/configure.ac b/opcodes/configure.ac
index b9f5eb8a4fd..b5ff57a341e 100644
--- a/opcodes/configure.ac
+++ b/opcodes/configure.ac
@@ -185,7 +185,7 @@ changequote([,])dnl
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"