summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-07-05 20:24:00 +0545
committerMike Frysinger <vapier@gentoo.org>2016-11-12 02:33:37 -0500
commit433808260786208f7691df0c313831549be5046f (patch)
tree5f175f1492cc1af97379f840ff84fe98e9d33b5f
parent7bf04c64fd51d82d1e860e4da1fbbd5ea6e23db8 (diff)
downloadbinutils-gdb-users/gentoo/2.27.tar.gz
opcodes: link against libbfd.la for rpath depsusers/gentoo/2.27
The reason opcodes doesn't link against libbfd.la is to workaround a libtool bug where it uses installed -L paths ahead of DESTDIR paths. The downside is that the library itself lacks rpath tags to find the right version of libbfd.so. Since Gentoo has patched the libtool bug for a while, we don't need the workaround. Use the .la file so we get the rpath tags. URL: https://bugs.gentoo.org/563934
-rwxr-xr-xopcodes/configure2
-rw-r--r--opcodes/configure.ac2
2 files changed, 2 insertions, 2 deletions
diff --git a/opcodes/configure b/opcodes/configure
index 5a4da066746..256d38aca29 100755
--- a/opcodes/configure
+++ b/opcodes/configure
@@ -12517,7 +12517,7 @@ if test "$enable_shared" = "yes"; then
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"
diff --git a/opcodes/configure.ac b/opcodes/configure.ac
index c7f47837186..6e3b05f0d26 100644
--- a/opcodes/configure.ac
+++ b/opcodes/configure.ac
@@ -185,7 +185,7 @@ changequote([,])dnl
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"