summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorGuo Yejun <yejun.guo@intel.com>2015-11-17 09:30:02 +0800
committerYang Rong <rong.r.yang@intel.com>2015-12-09 11:27:54 +0800
commitf72946236f3aba558685ebc9295731d945912f98 (patch)
tree82f4e9cd69883e9207ec521fb75a785125f2f876 /utests/CMakeLists.txt
parente2c46c88bd5bbd9f5762ba7ad3eaf00257ad114f (diff)
downloadbeignet-f72946236f3aba558685ebc9295731d945912f98.tar.gz
add utest to demo how to run CM kernerl via OpenCL APIs
In this test case, the CM kernel is in VISA binary format, not in GenX Binary format, it means that the CM jitter is needed to compile the CM kernel from VISA format to GenX format, please refer to cmrt_package_path/jitter/readme.txt to prepare the jitter. v2: add comments about the CM jitter Signed-off-by: Guo Yejun <yejun.guo@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index b4f8407f..b91c4ac5 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -238,6 +238,12 @@ else()
SET(UTESTS_REQUIRED_X11_LIB "")
endif (X11_FOUND)
+if (CMRT_FOUND)
+ SET(utests_sources
+ ${utests_sources}
+ runtime_cmrt.cpp)
+endif (CMRT_FOUND)
+
SET (kernel_bin ${CMAKE_CURRENT_SOURCE_DIR}/../kernels/compiler_ceil)
list (GET GBE_BIN_GENERATER -1 GBE_BIN_FILE)