summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorPan Xiuli <xiuli.pan@intel.com>2015-12-02 16:57:39 +0800
committerYang Rong <rong.r.yang@intel.com>2015-12-10 16:00:25 +0800
commitebe4161e2abd70bb0b6e69bd6d5909b083e60239 (patch)
tree0b5b7c4a597cb8071ee90b1376134b93087f7e04 /utests/CMakeLists.txt
parent16b0d62bb01fcc229aa92bc55a0a1c783a8043d5 (diff)
downloadbeignet-ebe4161e2abd70bb0b6e69bd6d5909b083e60239.tar.gz
Utest: Add test for get_global/local_linear_id
Add two utest case test for OCL2.0 new work-item built-in functions. Signed-off-by: Pan Xiuli <xiuli.pan@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index b91c4ac5..0bfd4a38 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -221,7 +221,9 @@ set (utests_sources
runtime_use_host_ptr_image.cpp
compiler_get_sub_group_size.cpp
compiler_get_sub_group_id.cpp
- compiler_sub_group_shuffle.cpp)
+ compiler_sub_group_shuffle.cpp
+ builtin_global_linear_id.cpp
+ builtin_local_linear_id.cpp)
if (LLVM_VERSION_NODOT VERSION_GREATER 34)
SET(utests_sources