summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorPan Xiuli <xiuli.pan@intel.com>2017-01-24 16:47:58 +0800
committerYang Rong <rong.r.yang@intel.com>2017-02-10 14:22:05 +0800
commit8726605ea77b5633c1f31c71e5a20aadcc38ed44 (patch)
tree582ebf0dc1b9228a0aab149eda78ff655e27330c /utests/CMakeLists.txt
parent85b948d174d404d5a3af097b8b216442f3e2931b (diff)
downloadbeignet-8726605ea77b5633c1f31c71e5a20aadcc38ed44.tar.gz
Utest: Add OCL20 into utest and check version in runtime
The utest should always be built and we can check ocl version at the test begin. Contributor: Rebecca N. Palmer <rebecca_palmer@zoho.com> Signed-off-by: Pan Xiuli <xiuli.pan@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt22
1 files changed, 9 insertions, 13 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index db61844f..43cf7f35 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -289,7 +289,15 @@ set (utests_sources
compiler_mix.cpp
compiler_math_3op.cpp
compiler_bsort.cpp
- builtin_kernel_block_motion_estimate_intel.cpp)
+ builtin_kernel_block_motion_estimate_intel.cpp
+ compiler_program_global.cpp
+ compiler_generic_atomic.cpp
+ compiler_atomic_functions_20.cpp
+ compiler_sampler.cpp
+ compiler_generic_pointer.cpp
+ runtime_pipe_query.cpp
+ compiler_pipe_builtin.cpp
+ compiler_device_enqueue.cpp)
if (LLVM_VERSION_NODOT VERSION_GREATER 34)
SET(utests_sources
@@ -297,18 +305,6 @@ if (LLVM_VERSION_NODOT VERSION_GREATER 34)
compiler_overflow.cpp)
endif (LLVM_VERSION_NODOT VERSION_GREATER 34)
-if (ENABLE_OPENCL_20)
- SET(utests_sources
- ${utests_sources}
- compiler_program_global.cpp
- compiler_generic_atomic.cpp
- compiler_atomic_functions_20.cpp
- compiler_sampler.cpp
- compiler_generic_pointer.cpp
- runtime_pipe_query.cpp
- compiler_pipe_builtin.cpp
- compiler_device_enqueue.cpp)
-endif (ENABLE_OPENCL_20)
if (NOT_BUILD_STAND_ALONE_UTEST)
if (X11_FOUND)