summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorRebecca N. Palmer <rebecca_palmer@zoho.com>2016-10-12 23:38:03 +0100
committerYang Rong <rong.r.yang@intel.com>2016-10-20 13:31:37 +0800
commit76f892abb0e8fa1e8ab60a926b84ba6fb14a5a7e (patch)
treeac5c95bab96d782e1fac4b003ccb9f7da1dea80d /utests/CMakeLists.txt
parent26f23c2a73ff08ba0f64333972bb15ce1d7ec155 (diff)
downloadbeignet-76f892abb0e8fa1e8ab60a926b84ba6fb14a5a7e.tar.gz
Utests: Allow testing cl_intel_accelerator via ICD
v3: Use extension check, not beignet check. Treat claiming to have the extension but not having the kernel as a failure. v4: Make extension check a function, use stderr. Signed-off-by: Rebecca N. Palmer <rebecca_palmer@zoho.com> Reviewed-by: Chuanbo Weng <chuanbo.weng@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 6a903284..8b33666b 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -287,7 +287,8 @@ set (utests_sources
multi_queue_events.cpp
compiler_mix.cpp
compiler_math_3op.cpp
- compiler_bsort.cpp)
+ compiler_bsort.cpp
+ builtin_kernel_block_motion_estimate_intel.cpp)
if (LLVM_VERSION_NODOT VERSION_GREATER 34)
SET(utests_sources
@@ -328,7 +329,6 @@ else(GEN_PCI_ID)
endif(GEN_PCI_ID)
if (NOT_BUILD_STAND_ALONE_UTEST)
- SET(utests_sources ${utests_sources} builtin_kernel_block_motion_estimate_intel.cpp)
ADD_CUSTOM_TARGET(kernel_bin.bin DEPENDS ${kernel_bin}.bin)
endif (NOT_BUILD_STAND_ALONE_UTEST)