summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorPan Xiuli <xiuli.pan@intel.com>2015-11-25 11:00:04 +0800
committerYang Rong <rong.r.yang@intel.com>2015-12-10 16:52:58 +0800
commit395fe59f2324a8f39f27432058794b5ed24d40b7 (patch)
tree0c110b97582e39824d5de17f54428e08e0948f65 /utests/CMakeLists.txt
parent8a667122c06e6f430c84adb1de3c27d77ebfd55e (diff)
downloadbeignet-395fe59f2324a8f39f27432058794b5ed24d40b7.tar.gz
utests: add an utest for mix
Add a testcase for compiler mix. Since mix will have error, we take err limit as 1e-3 and print the max err. Signed-off-by: Pan Xiuli <xiuli.pan@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 0bfd4a38..5b4657c0 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -223,7 +223,8 @@ set (utests_sources
compiler_get_sub_group_id.cpp
compiler_sub_group_shuffle.cpp
builtin_global_linear_id.cpp
- builtin_local_linear_id.cpp)
+ builtin_local_linear_id.cpp
+ compiler_mix.cpp)
if (LLVM_VERSION_NODOT VERSION_GREATER 34)
SET(utests_sources