summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorPan Xiuli <xiuli.pan@intel.com>2016-01-27 11:34:36 +0800
committerYang Rong <rong.r.yang@intel.com>2016-11-08 20:38:22 +0800
commit2ef247c021861182f9b0cf9f1eca924cd8d27f6b (patch)
treebb7f08ec027a8704bb82448b2e888b9b3104de8a /utests/CMakeLists.txt
parentc6755edb1256fdbf4dfa542fd6453d17f0718b72 (diff)
downloadbeignet-2ef247c021861182f9b0cf9f1eca924cd8d27f6b.tar.gz
Utest: Add pipe related test
Add test case for builtin with user struct type and int type and runtime tset for creatPipe and pipe query. Signed-off-by: Pan Xiuli <xiuli.pan@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 0ec1f8f2..0ca7f777 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -304,7 +304,9 @@ if (ENABLE_OPENCL_20)
compiler_generic_atomic.cpp
compiler_atomic_functions_20.cpp
compiler_sampler.cpp
- compiler_generic_pointer.cpp)
+ compiler_generic_pointer.cpp
+ runtime_pipe_query.cpp
+ compiler_pipe_builtin.cpp)
endif (ENABLE_OPENCL_20)
if (NOT_BUILD_STAND_ALONE_UTEST)