summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorRuiling Song <ruiling.song@intel.com>2016-01-19 11:29:06 +0800
committerYang Rong <rong.r.yang@intel.com>2016-11-08 20:38:21 +0800
commit295b1cb6d1ac616dd4d9b4b2ef14934b86e3ffbf (patch)
tree362d23da596fa3f4b222fdadead7431136b4516a /utests/CMakeLists.txt
parent07f879d60a62eb56f99d6e20f4bf363caf64a1ae (diff)
downloadbeignet-295b1cb6d1ac616dd4d9b4b2ef14934b86e3ffbf.tar.gz
GBE: Implement new constant solution for ocl2
Different from ocl 1.2, which gather all constant into one surface. ocl2 only gather program global/constant into one surface. But keep other constant passed through kernel argument in separate buffer. Signed-off-by: Ruiling Song <ruiling.song@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 7078a1fa..56add847 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -299,6 +299,7 @@ endif (LLVM_VERSION_NODOT VERSION_GREATER 34)
if (ENABLE_OPENCL_20)
SET(utests_sources
${utests_sources}
+ compiler_program_global.cpp
compiler_generic_pointer.cpp)
endif (ENABLE_OPENCL_20)