summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorPan Xiuli <xiuli.pan@intel.com>2015-12-11 13:28:57 +0800
committerYang Rong <rong.r.yang@intel.com>2015-12-14 16:22:13 +0800
commit0b1e6e2faffbc636801464c57be0969ac5cd91ee (patch)
treed7cc39c7a7f3ac9beebf8f43141a2745e4bbbd1b /utests/CMakeLists.txt
parent19fc80c432f748bd192d845ee58598352f0d898f (diff)
downloadbeignet-0b1e6e2faffbc636801464c57be0969ac5cd91ee.tar.gz
Utest: Add a bitonic sort test for non-constant extractelement
This test case is for the new added non-constand index extractelement path in llvm_scalarize pass. Signed-off-by: Pan Xiuli <xiuli.pan@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index 74189c62..d846b7b7 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -225,7 +225,8 @@ set (utests_sources
compiler_sub_group_shuffle.cpp
builtin_global_linear_id.cpp
builtin_local_linear_id.cpp
- compiler_mix.cpp)
+ compiler_mix.cpp
+ compiler_bsort.cpp)
if (LLVM_VERSION_NODOT VERSION_GREATER 34)
SET(utests_sources