summaryrefslogtreecommitdiff
path: root/utests/CMakeLists.txt
diff options
context:
space:
mode:
authorrander <rander.wang@intel.com>2017-05-23 10:03:27 +0800
committerYang Rong <rong.r.yang@intel.com>2017-06-09 20:03:01 +0800
commit05cff5c5475c3f43770b3dabc9119f0136936564 (patch)
treea64851cb30ac441920cfc8539ea22d5085acfd74 /utests/CMakeLists.txt
parentf8053378a254e0eac9b5b2188e81a0308e290647 (diff)
downloadbeignet-05cff5c5475c3f43770b3dabc9119f0136936564.tar.gz
utests: added for optimization negativeAdd
the negative Add is like: exp -a llvm transfer it to: add x -a, 0 exp x Signed-off-by: rander.wang <rander.wang@intel.com> Reviewed-by: Pan Xiuli <xiuli.pan@intel.com>
Diffstat (limited to 'utests/CMakeLists.txt')
-rw-r--r--utests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt
index f8abd457..afef07fc 100644
--- a/utests/CMakeLists.txt
+++ b/utests/CMakeLists.txt
@@ -304,7 +304,8 @@ set (utests_sources
runtime_pipe_query.cpp
compiler_pipe_builtin.cpp
compiler_device_enqueue.cpp
- compiler_sqrt_div.cpp)
+ compiler_sqrt_div.cpp
+ compiler_remove_negative_add.cpp)
if (LLVM_VERSION_NODOT VERSION_GREATER 34)
SET(utests_sources