summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Beckmann <anbe@debian.org>2015-02-07 04:45:32 +0100
committerZhigang Gong <zhigang.gong@intel.com>2015-02-11 12:57:07 +0800
commitc50154c65533dcac8105ec681aba6e85bcd0039f (patch)
tree458527edf9871a97bb19f16a1de7e209b31dd13c /CMakeLists.txt
parent1360f97238f3f8a9122abf581433de510804ace1 (diff)
downloadbeignet-c50154c65533dcac8105ec681aba6e85bcd0039f.tar.gz
remove unsafe define -D__$(USER)__
funny things may happen with usernames like 'asm', 'attribute', 'x86_64', 'i386', and so on this breaks on usernames with non-alnum chars ('-', '.') Signed-off-by: Andreas Beckmann <anbe@debian.org> Reviewed-by: Zhigang Gong <zhigang.gong@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01ec1d81..9c398e95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,8 +45,6 @@ if (NOT BEIGNET_INSTALL_DIR)
set (BEIGNET_INSTALL_DIR "${LIB_INSTALL_DIR}/beignet/")
endif (NOT BEIGNET_INSTALL_DIR)
-ADD_DEFINITIONS(-D__$(USER)__)
-
# Force Release with debug info
if (NOT CMAKE_BUILD_TYPE)
set (CMAKE_BUILD_TYPE RelWithDebInfo)