summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYang Rong <rong.r.yang@intel.com>2017-02-08 12:52:55 +0800
committerYang Rong <rong.r.yang@intel.com>2017-02-10 18:18:51 +0800
commitb875d0dc3a6e0ed0f48c473ca96e66066f3dc534 (patch)
treed34db5807ecd6973608062381d94c81edad44659 /CMakeLists.txt
parentc2dd07e788f7747b9ba841c9a50fcb2a74f22f85 (diff)
downloadbeignet-b875d0dc3a6e0ed0f48c473ca96e66066f3dc534.tar.gz
CMAKE: if user disable ICD support, must pass cmake option explicitly.
Also update readme aoubt ocl-icd section. Signed-off-by: Yang Rong <rong.r.yang@intel.com> Reviewed-by: Pan Xiuli <xiuli.pan@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4a4eda7..b6d7928c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -220,6 +220,7 @@ IF(OCLIcd_FOUND)
install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${ICD_FILE_NAME} DESTINATION /etc/OpenCL/vendors)
ELSE(OCLIcd_FOUND)
MESSAGE(STATUS "Looking for OCL ICD header file - not found")
+ MESSAGE(FATAL_ERROR "OCL ICD loader miss. If you really want to disable OCL ICD support, please run cmake with option -DOCLICD_COMPAT=0.")
ENDIF(OCLIcd_FOUND)
ENDIF(OCLICD_COMPAT)