summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZhenyu Wang <zhenyuw@linux.intel.com>2015-11-16 15:17:52 +0800
committerYang Rong <rong.r.yang@intel.com>2015-11-17 11:48:10 +0800
commitb075e218a170cd7622cc2186342d32d0fd052b4a (patch)
tree7b877e43e799ca74e81596a28aa7b667fdb67546 /CMakeLists.txt
parentb43f4df25752bf9b4b690aa27fe2bea622ce9b38 (diff)
downloadbeignet-b075e218a170cd7622cc2186342d32d0fd052b4a.tar.gz
First reference beignet's CL header to build
This is to fix build error when new intel extension is added into beignet. As current cmake rule will use old system installed CL headers instead of beignet ones, which leads to compile failure as new extension definition won't be found. So this trys to simply always prefer to use beignet's CL header in build/install. Signed-off-by: Zhenyu Wang <zhenyuw@linux.intel.com> Reviewed-by: "Yang, Rong R" <rong.r.yang@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c6c373b..147bb258 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,7 +32,9 @@ configure_file (
"src/OCLConfig.h"
)
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/include)
+
INCLUDE (FindPkgConfig)