summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@intel.com>2015-02-27 15:57:25 +0800
committerZhigang Gong <zhigang.gong@intel.com>2015-03-02 15:42:51 +0800
commit9666fb0504043d034ed1fcedb5bc4a864e58b68b (patch)
treeab0d69b8a817a5b7d7f6c16977db13b82fbd3f3b /CMakeLists.txt
parent601eab1ae830296ac10bfc7aa62efdaf75e76479 (diff)
downloadbeignet-9666fb0504043d034ed1fcedb5bc4a864e58b68b.tar.gz
Build: use -Bsymbolic to fix conflicts with other LLVM users.
As there may be some other LLVM users such as mesa, and they may link to different LLVM library. To avoid such type of conflicts, we use -Bsymbolic to disable the symbol preemption. This patch should fix the build bug at: https://bugs.freedesktop.org/show_bug.cgi?id=89325 Signed-off-by: Zhigang Gong <zhigang.gong@intel.com> Reviewed-by: "Yang, Rong R" <rong.r.yang@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4366d8c1..65f2c708 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,7 +100,7 @@ ELSE (USE_STANDALONE_GBE_COMPILER STREQUAL "true")
ENDIF (USE_STANDALONE_GBE_COMPILER STREQUAL "true")
-set (CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined ${LLVM_LDFLAGS}")
+set (CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,-Bsymbolic -Wl,--no-undefined ${LLVM_LDFLAGS}")
# XLib
Find_Package(X11)