summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuo, Yejun <yejun.guo@intel.com>2016-11-30 16:42:01 +0800
committerYang Rong <rong.r.yang@intel.com>2016-12-02 17:16:58 +0800
commit21ff3af7808b12bfc6abc6b3fbc4d3d09697acf6 (patch)
tree3a2a1b4dc51ae89b3811bfe5baf5efc3b7b57fa2 /CMakeLists.txt
parent0b82b53394227d560436c501cfc63aa316302bc8 (diff)
downloadbeignet-21ff3af7808b12bfc6abc6b3fbc4d3d09697acf6.tar.gz
disable CMRT as default, since no real case reported
and this feature also sometimes introduces build issue. v2: add option INVOKE_CMRT to enable CMRT if necessary Signed-off-by: Guo, Yejun <yejun.guo@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 713cfa94..9f529d4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -176,10 +176,15 @@ ELSE(DRM_INTEL_FOUND)
ENDIF(DRM_INTEL_FOUND)
# CMRT
+#disable CMRT as default, since we do not see real case,
+#but see build issue of this feature
+OPTION(INVOKE_CMRT "Enable CMRT" OFF)
+IF(INVOKE_CMRT)
pkg_check_modules(CMRT libcmrt)
IF(CMRT_FOUND)
INCLUDE_DIRECTORIES(${CMRT_INCLUDE_DIRS})
ENDIF(CMRT_FOUND)
+ENDIF(INVOKE_CMRT)
# Threads
Find_Package(Threads)