summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2021-11-25 23:54:16 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-11-25 23:54:16 +0300
commit8199a20978e5a3f637ca61975d6e81632b0113cb (patch)
treec0f220212f4f28c19b3c5aa84f824d5e51a127c9 /Makefile.am
parent07d08b8151401ef87792ff1f130b2fad738f306f (diff)
downloadbdwgc-8199a20978e5a3f637ca61975d6e81632b0113cb.tar.gz
Remove doc.am and move gc.man to base folder
(refactoring) This is to eliminate non-dist-doc files in doc folder. * CMakeLists.txt [enable_docs] (doc/gc.man): Rename to gc.man. * Makefile.am [ENABLE_DOCS] (dist_man3_MANS): Likewise. * Makefile.direct (BSD-pkg-install): Likewise. * Makefile.am: Do not include doc/doc.am. * Makefile.am [ENABLE_DOCS] (dist_doc_DATA, dist_man3_MANS): Copy assignment from doc.am. * doc/doc.am: Remove. * doc/gc.man: Rename to gc.man.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am44
1 files changed, 43 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a8f690c3..0859fecd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -206,9 +206,51 @@ EXTRA_DIST += tools/if_mach.c tools/if_not_there.c tools/setjmp_t.c \
include include/include.am
include cord/cord.am
include tests/tests.am
-include doc/doc.am
+
## Putting these at the top causes cord to be built first, and not find
## libgc.a on HP/UX. There may be a better fix.
+# Installed documentation.
+if ENABLE_DOCS
+dist_doc_DATA = \
+ AUTHORS \
+ LICENSE \
+ README.md \
+ doc/README.DGUX386 \
+ doc/README.Mac \
+ doc/README.OS2 \
+ doc/README.aix \
+ doc/README.amiga \
+ doc/README.arm.cross \
+ doc/README.autoconf \
+ doc/README.cmake \
+ doc/README.cords \
+ doc/README.darwin \
+ doc/README.emscripten \
+ doc/README.environment \
+ doc/README.ews4800 \
+ doc/README.hp \
+ doc/README.linux \
+ doc/README.macros \
+ doc/README.sgi \
+ doc/README.solaris2 \
+ doc/README.symbian \
+ doc/README.uts \
+ doc/README.win32 \
+ doc/README.win64 \
+ doc/debugging.md \
+ doc/finalization.md \
+ doc/gcdescr.md \
+ doc/gcinterface.md \
+ doc/leak.md \
+ doc/overview.md \
+ doc/porting.md \
+ doc/scale.md \
+ doc/simple_example.md \
+ doc/tree.md
+
+dist_man3_MANS = gc.man
+endif
+
# A dummy target for mono build.
test-bundle: