summaryrefslogtreecommitdiff
path: root/bc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bc/Makefile.am')
-rw-r--r--bc/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/bc/Makefile.am b/bc/Makefile.am
index 9187339..409e342 100644
--- a/bc/Makefile.am
+++ b/bc/Makefile.am
@@ -1,7 +1,8 @@
## Process this file with automake to produce Makefile.in
bin_PROGRAMS = bc
-bc_SOURCES = main.c bc.y scan.l execute.c load.c storage.c util.c global.c
+bc_SOURCES = main.c bc.y scan.l execute.c load.c storage.c util.c global.c \
+ warranty.c
EXTRA_DIST = bc.h bcdefs.h const.h fix-libmath_h global.h libmath.b proto.h \
sbc.y
@@ -9,16 +10,19 @@ noinst_HEADERS = libmath.h
DISTCLEANFILES = sbc sbc.c sbc.h
-MAINTAINERCLEANFILES = Makefile.in libmath.h bc.c bc.h scan.c
+MAINTAINERCLEANFILES = Makefile.in libmath.h bc.c bc.h scan.c \
+ bc.y bcdefs.h const.h execute.c fix-libmath_h \
+ global.c global.h libmath.b load.c main.c \
+ proto.h scan.l storage.c util.c
INCLUDES = -I$(srcdir) -I$(srcdir)/../h
LIBBC = ../lib/libbc.a
LIBL = @LEXLIB@
LDADD = $(LIBBC) $(LIBL) @READLINELIB@
-YFLAGS = -d
+AM_YFLAGS = -d
-CFLAGS = @CFLAGS@ -Wall -funsigned-char
+AM_CFLAGS = @CFLAGS@
$(PROGRAMS): $(LIBBC)
@@ -30,13 +34,15 @@ libmath.h: libmath.b
$(MAKE) fbc
./fbc -c $(srcdir)/libmath.b </dev/null >libmath.h
$(srcdir)/fix-libmath_h
- rm -f ./fbc
+ rm -f ./fbc ./global.o
-fbcOBJ = main.o bc.o scan.o execute.o global.o load.o storage.o util.o
+fbcOBJ = main.o bc.o scan.o execute.o global.o load.o storage.o util.o \
+ warranty.o
fbc: $(fbcOBJ)
$(LINK) $(fbcOBJ) $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)
-sbcOBJ = main.o sbc.o scan.o execute.o global.o load.o storage.o util.o
+sbcOBJ = main.o sbc.o scan.o execute.o global.o load.o storage.o util.o \
+ warranty.o
sbc.o: sbc.c
sbc: $(sbcOBJ)
$(LINK) $(sbcOBJ) $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)