summaryrefslogtreecommitdiff
path: root/bc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bc/Makefile.am')
-rw-r--r--bc/Makefile.am36
1 files changed, 20 insertions, 16 deletions
diff --git a/bc/Makefile.am b/bc/Makefile.am
index 9187339..d9d412e 100644
--- a/bc/Makefile.am
+++ b/bc/Makefile.am
@@ -1,42 +1,46 @@
## Process this file with automake to produce Makefile.in
bin_PROGRAMS = bc
-bc_SOURCES = main.c bc.y scan.l execute.c load.c storage.c util.c global.c
+bc_SOURCES = main.c bc.y scan.l execute.c load.c storage.c util.c global.c \
+ warranty.c
EXTRA_DIST = bc.h bcdefs.h const.h fix-libmath_h global.h libmath.b proto.h \
sbc.y
noinst_HEADERS = libmath.h
-DISTCLEANFILES = sbc sbc.c sbc.h
+DISTCLEANFILES = sbc sbc.c sbc.h libmath.h
-MAINTAINERCLEANFILES = Makefile.in libmath.h bc.c bc.h scan.c
+MAINTAINERCLEANFILES = Makefile.in bc.c bc.h scan.c \
+ bc.y bcdefs.h const.h execute.c fix-libmath_h \
+ global.c global.h libmath.b load.c main.c \
+ proto.h scan.l storage.c util.c
-INCLUDES = -I$(srcdir) -I$(srcdir)/../h
+AM_CPPFLAGS = -I$(srcdir) -I$(srcdir)/../h
LIBBC = ../lib/libbc.a
LIBL = @LEXLIB@
LDADD = $(LIBBC) $(LIBL) @READLINELIB@
-YFLAGS = -d
+AM_YFLAGS = -d
-CFLAGS = @CFLAGS@ -Wall -funsigned-char
+AM_CFLAGS = @CFLAGS@
-$(PROGRAMS): $(LIBBC)
+$(PROGRAMS): libmath.h $(LIBBC)
scan.o: bc.h
global.o: libmath.h
-libmath.h: libmath.b
+fbcOBJ = main.o bc.o scan.o execute.o load.o storage.o util.o warranty.o
+
+libmath.h: libmath.b $(fbcOBJ) $(LIBBC)
echo '{0}' > libmath.h
- $(MAKE) fbc
+ $(MAKE) global.o
+ $(LINK) -o fbc $(fbcOBJ) global.o $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)
./fbc -c $(srcdir)/libmath.b </dev/null >libmath.h
$(srcdir)/fix-libmath_h
- rm -f ./fbc
-
-fbcOBJ = main.o bc.o scan.o execute.o global.o load.o storage.o util.o
-fbc: $(fbcOBJ)
- $(LINK) $(fbcOBJ) $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)
+ rm -f ./fbc ./global.o
-sbcOBJ = main.o sbc.o scan.o execute.o global.o load.o storage.o util.o
+sbcOBJ = main.o sbc.o scan.o execute.o global.o load.o storage.o util.o \
+ warranty.o
sbc.o: sbc.c
-sbc: $(sbcOBJ)
+sbc: $(sbcOBJ) $(LIBBC)
$(LINK) $(sbcOBJ) $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)