summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6703d74
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,18 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = lib bc dc doc
+
+MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in \
+ $(distdir).tar.gz h/number.h
+
+dist-hook:
+ mkdir $(distdir)/h $(distdir)/Examples $(distdir)/Test
+ cp -p $(srcdir)/h/*.h $(distdir)/h
+ cp -p $(srcdir)/Examples/*.b $(distdir)/Examples
+ cp -p $(srcdir)/Test/*.b $(srcdir)/Test/*.bc $(distdir)/Test
+ cp -p $(srcdir)/Test/signum $(srcdir)/Test/timetest $(distdir)/Test
+ cp -p $(srcdir)/lib/testmul.c $(distdir)/lib
+ cp -p $(srcdir)/FAQ $(distdir)
+
+timetest:
+ (cd lib; $(MAKE) specialnumber)