summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristopher Lenz <cmlenz@gmail.com>2007-06-15 18:27:38 +0000
committerChristopher Lenz <cmlenz@gmail.com>2007-06-15 18:27:38 +0000
commitce4e27cc7f8f4c1faee0749bc8da6c02f9519922 (patch)
tree60daa35aa0f5d40260bb9d574bd33b122fd2c3a8 /setup.py
parentbb1599d6bd0df41679a83a3e31cd70069f4c2a81 (diff)
downloadbabel-ce4e27cc7f8f4c1faee0749bc8da6c02f9519922.tar.gz
Moved doc config into a subdirectory, and added a `--force` option to the `build_doc` command.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py13
1 files changed, 8 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index b27adc9..8efd523 100755
--- a/setup.py
+++ b/setup.py
@@ -26,12 +26,15 @@ import sys
class build_doc(Command):
description = 'Builds the documentation'
user_options = [
+ ('force', None,
+ "force regeneration even if no reStructuredText files have changed"),
('without-apidocs', None,
"whether to skip the generation of API documentaton"),
]
- boolean_options = ['without-apidocs']
+ boolean_options = ['force', 'without-apidocs']
def initialize_options(self):
+ self.force = False
self.without_apidocs = False
def finalize_options(self):
@@ -42,8 +45,8 @@ class build_doc(Command):
from docutils.nodes import raw
from docutils.parsers import rst
- docutils_conf = os.path.join('doc', 'docutils.conf')
- epydoc_conf = os.path.join('doc', 'epydoc.conf')
+ docutils_conf = os.path.join('doc', 'conf', 'docutils.ini')
+ epydoc_conf = os.path.join('doc', 'conf', 'epydoc.ini')
try:
from pygments import highlight
@@ -64,8 +67,8 @@ class build_doc(Command):
for source in glob('doc/*.txt'):
dest = os.path.splitext(source)[0] + '.html'
- if not os.path.exists(dest) or \
- os.path.getmtime(dest) < os.path.getmtime(source):
+ if self.force or not os.path.exists(dest) or \
+ os.path.getmtime(dest) < os.path.getmtime(source):
print 'building documentation file %s' % dest
publish_cmdline(writer_name='html',
argv=['--config=%s' % docutils_conf, source,