summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2009-12-18 17:59:22 +0100
committerPeter Simons <simons@cryp.to>2009-12-18 17:59:22 +0100
commitc6afe2870fb07eb45057bf8b7a8dea304bce7189 (patch)
tree93ba6b8be326d8a720c28b2ad804df7ff976df65 /configure.ac
parent423e44c801144c2d6b9705fe676de057469a9b8d (diff)
downloadautoconf-archive-c6afe2870fb07eb45057bf8b7a8dea304bce7189.tar.gz
configure.ac: fixed detection of available texinfo documentation
This shell-pattern stuff really needs to be replaced ASAP. This is very unreliable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index da6245f..1915274 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,10 +29,10 @@ AC_MSG_RESULT([done])
AC_MSG_CHECKING([for available Texinfo documentation])
TEXIFILE=""
-(cd ${srcdir}/doc
-for n in *.texi ; do
- TEXIFILE="${TEXIFILE} ${n}"
-done)
+for n in ${srcdir}/doc/*.texi ; do
+ m=`basename ${n}`
+ TEXIFILE="${TEXIFILE} ${m}"
+done
AC_SUBST([TEXIFILE])
AC_MSG_RESULT([done])