summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2009-12-27 20:28:08 +0100
committerPeter Simons <simons@cryp.to>2009-12-27 22:22:33 +0100
commit03431481dc839f15365e0d86882b4fe1befd31bf (patch)
tree0a6002471bab8d9a953e8197d5188d3621d6cca6 /configure.ac
parent7d60e47f4f3fc8b84ee486f92b1f4365aa8dbda1 (diff)
downloadautoconf-archive-03431481dc839f15365e0d86882b4fe1befd31bf.tar.gz
configure.ac: determine the set of available macros at time "autoconf" is run
This approach has the advantage that the Archive's installation procedure doesn't depend on any shell-specific behavior at all; the set of available macros is statically built into the configure script. Gnulib's dist target ensures that this information is up-to-date whenever a release archive is compiled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 5 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 1915274..82da3c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,22 +19,11 @@ General Public License for more details.])
AC_MSG_NOTICE([Autoconf Archive version $VERSION])
-AC_MSG_CHECKING([for available macros])
-M4SOURCE=""
-for n in ${srcdir}/m4/*.m4 ; do
- M4SOURCE="${M4SOURCE} ${n}"
-done
-AC_SUBST([M4SOURCE])
-AC_MSG_RESULT([done])
-
-AC_MSG_CHECKING([for available Texinfo documentation])
-TEXIFILE=""
-for n in ${srcdir}/doc/*.texi ; do
- m=`basename ${n}`
- TEXIFILE="${TEXIFILE} ${m}"
-done
-AC_SUBST([TEXIFILE])
-AC_MSG_RESULT([done])
+M4FILES="m4_esyscmd([echo -n m4/*.m4])"
+AC_SUBST([M4FILES])
+
+TEXIFILES="m4_esyscmd([cd m4 && echo -n *.m4 | sed -e 's/\.m4/.texi/g'])"
+AC_SUBST([TEXIFILES])
AC_CONFIG_FILES([Makefile doc/Makefile])
AC_OUTPUT