summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2009-09-19 01:51:54 +0200
committerPeter Simons <simons@cryp.to>2009-09-21 22:57:53 +0200
commita6b2d7b20dbcf1ac19aa9bdf78a9ba575f86f7ac (patch)
tree5775cb1997e6f4a0dd0c43f992a98bdd265bd32a /Makefile.am
parente55e85ee99349e35719361937cefa6c485646f63 (diff)
downloadautoconf-archive-a6b2d7b20dbcf1ac19aa9bdf78a9ba575f86f7ac.tar.gz
ChangeLog: automatically generate the file in dist-hook
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7751cf0..92d0c4e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,15 +13,12 @@ dist_html_DATA = $(HTMLFILE)
info_TEXINFOS = autoconf-archive.texi
-EXTRA_DIST = build-aux/git-version-gen $(TEXIFILE)
+EXTRA_DIST = build-aux/git-version-gen build-aux/gitlog-to-changelog $(TEXIFILE)
autoconf-archive.info: $(TEXIFILE)
# maintainer rules
-dist-hook:
- echo $(VERSION) > $(distdir)/.tarball-version
-
clean-local:
@rm -rf $(srcdir)/stage $(srcdir)/macro.pyc
@rm -f $(DIST_ARCHIVES)
@@ -30,4 +27,13 @@ maintainer-clean-local:
@rm -rf $(srcdir)/build-aux
@rm -f configure Makefile.in aclocal.m4 AUTHORS ChangeLog
@rm -f INSTALL config.log config.status configure maint.mk
- @rm -f autoconf-archive-*.*.*.tar.* GNUmakefile
+ @rm -f autoconf-archive-*.*.*.tar.* GNUmakefile COPYING
+
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
+ if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ >$(distdir)/cl-t -- master $(top_srcdir)/m4; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi