summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2009-07-21 00:39:39 +0200
committerPeter Simons <simons@cryp.to>2009-07-21 02:30:37 +0200
commit148210e6c0f6d42211ec94b3bb75050da1a722ef (patch)
tree80399491370da450b9a58ff93816f170ffe7b9e1 /Makefile.am
parent72d0b562adb6c431ef78189afb5559a09d4b0346 (diff)
downloadautoconf-archive-148210e6c0f6d42211ec94b3bb75050da1a722ef.tar.gz
maint: use maintainer-makefile module from gnulib
Gnulib is now registered as a submodule. Please run "git submodule init" to update your checked-out copy.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8805360..ca7f018 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,9 @@
-# Install the Autoconf Archive
+# Build and install the Autoconf Archive.
#
# Copyright (c) 2009 by Peter Simons <simons@cryp.to>
# Licensed under the terms of the GNU General Public License.
dist_pkgdata_DATA = AUTHORS COPYING README
-CLEANFILES = $(DIST_ARCHIVES)
-MAINTAINERCLEANFILES = missing install-sh configure Makefile.in aclocal.m4
aclocaldir = $(datadir)/aclocal
dist_aclocal_DATA = $(M4SOURCE)
@@ -15,5 +13,17 @@ dist_html_DATA = $(HTMLFILE)
EXTRA_DIST = build-aux/git-version-gen
+# maintainer rules
+
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
+
+clean-local:
+ @rm -rf $(srcdir)/stage $(srcdir)/macro.pyc
+ @rm -f $(DIST_ARCHIVES)
+
+maintainer-clean-local:
+ @rm -rf $(srcdir)/build-aux
+ @rm -f configure Makefile.in aclocal.m4 AUTHORS ChangeLog
+ @rm -f INSTALL config.log config.status configure maint.mk
+ @rm -f autoconf-archive-*.*.*.tar.* GNUmakefile