summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/routingInterface/CMakeLists.txt
diff options
context:
space:
mode:
authorchristian mueller <christian.ei.mueller@bmw.de>2012-02-29 13:27:27 +0100
committerchristian mueller <christian.ei.mueller@bmw.de>2012-02-29 13:27:27 +0100
commitd3ccf97331935b181041394b80be20dca282ea71 (patch)
treef85e7b649c8a6d58c11e9728b2442cdcff53826d /AudioManagerDaemon/test/routingInterface/CMakeLists.txt
parentaa93713377d28a8ce7821466ef828f79a18e982d (diff)
downloadaudiomanager-d3ccf97331935b181041394b80be20dca282ea71.tar.gz
* [ performance] for classes that do not need to be derived from, removed virtual desctructor
* implemented confirmation of routing ready in RoutingReceiver * [Sockethandler] automatically set gDispatchDone to 0 when starting mainloop * fixed unit text to work with latest changes (expect Dbus command interface) * [GAM-4] added way to do synchronous calling on interfaces with the help of CAmSerializer.h * reworked AsyncRoutingPlugin to work with CAmSerializer.h * reworked AsyncRoutingPlugin to register elemtes in thread using CAmSerializer.h * reworked AsncPlugin Tests to work with remodelled Plugin
Diffstat (limited to 'AudioManagerDaemon/test/routingInterface/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/routingInterface/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/AudioManagerDaemon/test/routingInterface/CMakeLists.txt b/AudioManagerDaemon/test/routingInterface/CMakeLists.txt
index 5b5da3c..fbb4ac1 100644
--- a/AudioManagerDaemon/test/routingInterface/CMakeLists.txt
+++ b/AudioManagerDaemon/test/routingInterface/CMakeLists.txt
@@ -54,6 +54,9 @@ file(GLOB ROUTING_INTERFACE_SRCS_CXX
"../../src/ControlSender.cpp"
"../CommonFunctions.cpp"
"../../src/DLTWrapper.cpp"
+ "../../src/SocketHandler.cpp"
+ "../../src/RoutingReceiver.cpp"
+ "../../src/CommandReceiver.cpp"
"*.cpp"
)