summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Linke <christian.linke@bmw.de>2015-12-02 17:25:12 +0000
committerChristian Linke <christian.linke@bmw.de>2015-12-02 17:25:12 +0000
commit3f8431c8d0886dd18ab157694a64766a2d7288bd (patch)
tree92e6743dd11f74a0862c1b69ec36e5cd364b39ff /AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
parent2312c029d469fcc00bc465f44c398f6460cb51e5 (diff)
downloadaudiomanager-3f8431c8d0886dd18ab157694a64766a2d7288bd.tar.gz
moved watchdog into utilities and created .pc file for utilities
Signed-off-by: Christian Linke <christian.linke@bmw.de>
Diffstat (limited to 'AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt b/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
index d4e2580..e9b0e80 100644
--- a/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
@@ -25,6 +25,13 @@ set (AM_LINK_LIBS
${CMAKE_DL_LIBS}
AudioManagerUtilities
rt)
+
+IF (WITH_CAPI_WRAPPER)
+ set (AM_LINK_LIBS
+ ${AM_LINK_LIBS}
+ -Wl,--as-needed CommonAPI
+ )
+ENDIF (WITH_CAPI_WRAPPER)
if(WITH_DLT)
pkg_check_modules(DLT REQUIRED automotive-dlt>=2.2.0)