summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Lorenz <jlorenz@de.adit-jv.com>2015-09-15 14:32:18 +0200
committerChristian Linke <christian.linke@bmw.de>2015-10-06 19:28:39 +0100
commit276ec7d3e207f089cf9cd1dd375bf8508fc4cde3 (patch)
tree85168407994ee90d2aecbfd2c5f2ed6c379fea89 /AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
parentaf5b8d11ef93907ea9593fd61b56340f0a410ea2 (diff)
downloadaudiomanager-276ec7d3e207f089cf9cd1dd375bf8508fc4cde3.tar.gz
Utilities now build as a static or as a shared library on demand.
Signed-off-by: Jens Lorenz <jlorenz@de.adit-jv.com>
Diffstat (limited to 'AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt b/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
index b19f6f1..d4e2580 100644
--- a/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmRouterTest/CMakeLists.txt
@@ -23,6 +23,7 @@ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -DUNIT_TEST=1 -DDLT_CONTEXT=AudioMan
set (AM_LINK_LIBS
${CMAKE_DL_LIBS}
+ AudioManagerUtilities
rt)
if(WITH_DLT)
@@ -49,8 +50,6 @@ file(GLOB ROUTING_SRCS_CXX
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmControlReceiver.cpp"
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmControlSender.cpp"
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmRouter.cpp"
- "${AUDIOMANAGER_UTILITIES_SRC}/CAmDltWrapper.cpp"
- "${AUDIOMANAGER_UTILITIES_SRC}/CAmSocketHandler.cpp"
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmCommandReceiver.cpp"
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmRoutingReceiver.cpp"
"../CAmCommonFunctions.cpp"
@@ -62,9 +61,10 @@ ADD_EXECUTABLE( AmRouterTest ${ROUTING_SRCS_CXX})
TARGET_LINK_LIBRARIES(AmRouterTest
${AM_LINK_LIBS}
gtest
- gmock)
+ gmock
+)
-ADD_DEPENDENCIES(AmRouterTest gtest gmock)
+ADD_DEPENDENCIES(AmRouterTest gtest gmock AudioManagerUtilities)
INSTALL(TARGETS AmRouterTest
DESTINATION ${TEST_EXECUTABLE_INSTALL_PATH}