summaryrefslogtreecommitdiff
path: root/AudioManagerCore/test/AmMapHandlerTest/CMakeLists.txt
diff options
context:
space:
mode:
authorAleksandar Donchev <Aleksander.Donchev@partner.bmw.de>2017-05-19 11:55:01 +0200
committerJacqueline Molz <Jacqueline.Molz@bmw.de>2017-07-10 12:35:05 +0200
commitbe63615585049aa4045f13e91291d64b0a9ed5a3 (patch)
tree9baabfbf751e85d0980f74e55e8332f6e20c379f /AudioManagerCore/test/AmMapHandlerTest/CMakeLists.txt
parent375dc7b81795da9bfd8372f629d7fcef704a6d58 (diff)
downloadaudiomanager-be63615585049aa4045f13e91291d64b0a9ed5a3.tar.gz
The primary signals SIGINT and SIGQUIT are handled on top level in
contrast to secondary signals SIGHUP, SIGTERM, SIGCHLD, which are handled in the SocketHandler. Signed-off-by: Christian Linke <christian.linke@bmw.de> Change-Id: I8c5d3c436ac9fcd61c76a26145c731b427cab1e6
Diffstat (limited to 'AudioManagerCore/test/AmMapHandlerTest/CMakeLists.txt')
-rw-r--r--AudioManagerCore/test/AmMapHandlerTest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/AudioManagerCore/test/AmMapHandlerTest/CMakeLists.txt b/AudioManagerCore/test/AmMapHandlerTest/CMakeLists.txt
index 41c62c7..5a74cba 100644
--- a/AudioManagerCore/test/AmMapHandlerTest/CMakeLists.txt
+++ b/AudioManagerCore/test/AmMapHandlerTest/CMakeLists.txt
@@ -36,6 +36,7 @@ ADD_EXECUTABLE( AmMapHandlerTest ${DATABASE_SRCS_CXX})
TARGET_LINK_LIBRARIES( AmMapHandlerTest
${GTEST_LIBRARIES}
${GMOCK_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT}
AudioManagerCore
)