summaryrefslogtreecommitdiff
path: root/AudioManagerCore/test/AmControlInterfaceTest/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Linke <Christian.Linke@bmw.de>2016-02-11 07:28:47 +0100
committerChristian Linke <Christian.Linke@bmw.de>2016-02-15 09:00:59 +0100
commit5bcd206b9270d9a79e212f91723ea1a08a4d4859 (patch)
tree55b0cd4d07fbd7ebfd15d58d02e9cae6ae61b127 /AudioManagerCore/test/AmControlInterfaceTest/CMakeLists.txt
parent59080ecc2c8840fd85c561adea3f85f5344534a8 (diff)
downloadaudiomanager-5bcd206b9270d9a79e212f91723ea1a08a4d4859.tar.gz
* rework of the build structure, adopt to standard cmake package structure7.4
* check versions when loading the libs * introduction of the AudioManagerCore * give control plugin as file or directory * remove SQLITE * either find and use gmock or build and install it * fixed [Bug 411] * compile flag gnu11 is now used Signed-off-by: Christian Linke <Christian.Linke@bmw.de> Signed-off-by: Christian Linke <Christian.Linke@bmw.de>
Diffstat (limited to 'AudioManagerCore/test/AmControlInterfaceTest/CMakeLists.txt')
-rw-r--r--AudioManagerCore/test/AmControlInterfaceTest/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/AudioManagerCore/test/AmControlInterfaceTest/CMakeLists.txt b/AudioManagerCore/test/AmControlInterfaceTest/CMakeLists.txt
new file mode 100644
index 0000000..4f33ac5
--- /dev/null
+++ b/AudioManagerCore/test/AmControlInterfaceTest/CMakeLists.txt
@@ -0,0 +1,52 @@
+# Copyright (C) 2012, BMW AG
+#
+# This file is part of GENIVI Project AudioManager.
+#
+# Contributions are licensed to the GENIVI Alliance under one or more
+# Contribution License Agreements.
+#
+# copyright
+# This Source Code Form is subject to the terms of the
+# Mozilla Public License, v. 2.0. if a copy of the MPL was not distributed with
+# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# author Christian Linke, christian.linke@bmw.de BMW 2011,2012
+#
+# For further information see http://www.genivi.org/.
+#
+
+cmake_minimum_required(VERSION 3.0)
+
+project(AmControlInterfaceTest LANGUAGES CXX VERSION ${DAEMONVERSION})
+
+INCLUDE_DIRECTORIES(
+ ${AUDIOMANAGER_CORE_INCLUDE}
+ ${GMOCK_INCLUDE_DIRS}
+ ${GTEST_INCLUDE_DIRS})
+
+
+ file(GLOB CONTROL_INTERFACE_SRCS_CXX
+ "../CAmCommonFunctions.cpp"
+ "*.cpp"
+)
+
+add_executable(AmControlInterfaceTest ${CONTROL_INTERFACE_SRCS_CXX})
+
+TARGET_LINK_LIBRARIES(AmControlInterfaceTest
+ ${GTEST_LIBRARIES}
+ ${GMOCK_LIBRARIES}
+ AudioManagerCore
+)
+
+add_test(AmControlInterfaceTest AmControlInterfaceTest)
+
+ADD_DEPENDENCIES(AmControlInterfaceTest AudioManagerCore)
+
+INSTALL(TARGETS AmControlInterfaceTest
+ DESTINATION ${TEST_EXECUTABLE_INSTALL_PATH}
+ PERMISSIONS OWNER_EXECUTE OWNER_WRITE OWNER_READ GROUP_EXECUTE GROUP_READ WORLD_EXECUTE WORLD_READ
+ COMPONENT tests)
+
+
+
+