summaryrefslogtreecommitdiff
path: root/atk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'atk/Makefile.am')
-rw-r--r--atk/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/atk/Makefile.am b/atk/Makefile.am
new file mode 100644
index 0000000..df17806
--- /dev/null
+++ b/atk/Makefile.am
@@ -0,0 +1,49 @@
+
+lib_LTLIBRARIES = libatk.la
+
+libatk_la_SOURCES = \
+ atkaction.c \
+ atkcomponent.c \
+ atkeditabletext.c \
+ atkhyperlink.c \
+ atkhypertext.c \
+ atkimage.c \
+ atknoopobject.c \
+ atknoopobject.h \
+ atknoopobjectfactory.c \
+ atknoopobjectfactory.h \
+ atkobject.c \
+ atkobjectfactory.c \
+ atkregistry.c \
+ atkselection.c \
+ atktable.c \
+ atktext.c \
+ atkutil.c \
+ atkvalue.c
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ @DEP_CFLAGS@
+
+LDFLAGS = \
+ -no-undefined \
+ @DEP_LIBS@
+
+libatkincludedir=$(includedir)/atk
+
+libatkinclude_HEADERS = \
+ atk.h \
+ atkaction.h \
+ atkcomponent.h \
+ atkeditabletext.h \
+ atkhyperlink.h \
+ atkhypertext.h \
+ atkobject.h \
+ atkobjectfactory.h \
+ atkimage.h \
+ atkregistry.h \
+ atkselection.h \
+ atktable.h \
+ atktext.h \
+ atkutil.h \
+ atkvalue.h