summaryrefslogtreecommitdiff
path: root/atk/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-01-10 18:29:44 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-01-10 18:29:44 +0800
commit80f310a52682e71df05ccd98b0e79c7603f72164 (patch)
tree1bfd5b8a127813bb69210665dfce94d1a5ff0e6d /atk/Makefile.am
parent5bd4797eccfdc9edf03282b41481f296dc80b980 (diff)
downloadatk-80f310a52682e71df05ccd98b0e79c7603f72164.tar.gz
Visual Studio projects: Move to win32/
It was suggested that the project be moved to win32/, so that one will need to go one less layer down into the tree to reach the project files.
Diffstat (limited to 'atk/Makefile.am')
-rw-r--r--atk/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/atk/Makefile.am b/atk/Makefile.am
index 875f616..660b26b 100644
--- a/atk/Makefile.am
+++ b/atk/Makefile.am
@@ -213,17 +213,17 @@ atk_EXCLUDES = atkdummy
atk_HEADERS_DIR = $(libatkincludedir)
atk_HEADERS_INST = $(libatkinclude_HEADERS) atkversion.h
-atk_HEADERS_EXCLUDES = $(top_builddir)/atk/atkversion.h
+atk_HEADERS_EXCLUDES = $(builddir)/atkversion.h
-include $(top_srcdir)/build/Makefile.msvcproj
+include $(top_srcdir)/win32/Makefile.msvcproj
if HAVE_INTROSPECTION
# Introspection Items for MSVC
MSVC_INTROSPECT_GIRS = Atk-1.0.gir
INTROSPECTION_INTERMEDIATE_ITEMS = \
- $(top_builddir)/build/win32/Atk-1.0.gir.msvc.introspect \
- $(top_builddir)/build/win32/Atk_1_0_gir_list
+ $(top_builddir)/win32/Atk-1.0.gir.msvc.introspect \
+ $(top_builddir)/win32/Atk_1_0_gir_list
Atk_1_0_gir_MSVC_EXPORT_PACKAGES = atk
Atk_1_0_gir_MSVC_INCLUDE_GIRS = $(Atk_1_0_gir_INCLUDES)
@@ -235,7 +235,7 @@ Atk_1_0_gir_MSVC_FILES = \
atk-enum-types.h
Atk_1_0_gir_MSVC_CFLAGS = \
- -I../.. \
+ -I.. \
-DG_DISABLE_DEPRECATED \
-DATK_DISABLE_DEPRECATED \
-DATK_COMPILATION \
@@ -243,15 +243,15 @@ Atk_1_0_gir_MSVC_CFLAGS = \
Atk_1_0_gir_MSVC_SCANNERFLAGS = --warn-all --c-include "atk/atk.h"
-include $(top_srcdir)/build/Makefile.msvc-introspection
+include $(top_srcdir)/win32/Makefile.msvc-introspection
else
INTROSPECTION_INTERMEDIATE_ITEMS =
endif
dist-hook: \
- $(top_builddir)/build/win32/vs9/atk.vcproj \
- $(top_builddir)/build/win32/vs9/atk.headers \
+ $(top_builddir)/win32/vs9/atk.vcproj \
+ $(top_builddir)/win32/vs9/atk.headers \
$(INTROSPECTION_INTERMEDIATE_ITEMS)
distclean-local: