summaryrefslogtreecommitdiff
path: root/atk/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2003-02-25 22:06:37 +0000
committerTor Lillqvist <tml@src.gnome.org>2003-02-25 22:06:37 +0000
commit7667bbd34aa6278f7a8f83e7acf798b15adc0fd3 (patch)
tree603e065bdfec0441a0fb5a160c9e2df7fab41b27 /atk/Makefile.am
parentbda58843f3f1d48842144720589de162379ea4ed (diff)
downloadatk-7667bbd34aa6278f7a8f83e7acf798b15adc0fd3.tar.gz
Dist atk-zip.sh.in, not atk-zip.sh.
2003-02-25 Tor Lillqvist <tml@iki.fi> * Makefile.am (EXTRA_DIST): Dist atk-zip.sh.in, not atk-zip.sh. * atk/atk.def: Add a couple of missing entries, thanks to Cedric Gustin. * atk/atk.rc.in: New file, for version info in the DLL on Windows. Similar as in GLib, GTK, etc. * configure.in: Generate atk/atk.rc. * atk/Makefile.am: Use atk.rc on Windows. (EXTRA_DIST): Distribute atk.rc(.in). * atk/atkobject.c: On Windows, don't use hardcoded ATKLOCALEDIR, but deduce it from DLL location, like GLib, GTK etc do.
Diffstat (limited to 'atk/Makefile.am')
-rw-r--r--atk/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/atk/Makefile.am b/atk/Makefile.am
index 4e19235..40e1c6f 100644
--- a/atk/Makefile.am
+++ b/atk/Makefile.am
@@ -2,11 +2,14 @@
# which are more like other make's VPATH.
GPATH = $(srcdir)
-EXTRA_DIST = atk.def
+EXTRA_DIST = atk.def atk.rc atk.rc.in
+
if OS_WIN32
export_symbols = -export-symbols atk.def
no_undefined = -no-undefined
+atk_win32res = atk-win32res.lo
+
install-libtool-import-lib:
$(INSTALL) .libs/libatk-$(ATK_API_VERSION).dll.a $(DESTDIR)$(libdir)
uninstall-libtool-import-lib:
@@ -62,6 +65,9 @@ libatk_1_0_la_SOURCES = \
atkvalue.c \
$(atk_built_cfiles)
+libatk_1_0_la_LIBADD = $(atk_win32res)
+libatk_1_0_la_DEPENDENCIES = $(atk_win32res)
+
EXTRA_DIST += atkmarshal.list \
atkintl.h
@@ -118,6 +124,9 @@ libatkinclude_HEADERS = \
$(libatk_1_0_la_OBJECTS): atkmarshal.c atkmarshal.h $(atk_built_headers)
+atk-win32res.lo: atk.rc
+ $(top_srcdir)/../glib/build/win32/lt-compile-resource atk.rc atk-win32res.lo
+
atkmarshal.h: @REBUILD@ stamp-atkmarshal.h
@true
stamp-atkmarshal.h: atkmarshal.list