summaryrefslogtreecommitdiff
path: root/atk/Makefile.am
diff options
context:
space:
mode:
authorLi Yuan <li.yuan@sun.com>2008-06-19 08:13:52 +0000
committerLi Yuan <liyuan@src.gnome.org>2008-06-19 08:13:52 +0000
commit0c469d095284d062b512d0e9f4ea436b7d725f5b (patch)
treec521a494607b65caee140965d09528e6b3dae635 /atk/Makefile.am
parentc28f5c56779bea856f207e746d63218b7fde51c0 (diff)
downloadatk-0c469d095284d062b512d0e9f4ea436b7d725f5b.tar.gz
Patch from Mike Gorse <mgorse@novell.com>. Bug #526752. Mark deprecated
2008-06-19 Li Yuan <li.yuan@sun.com> * atk/Makefile.am: * atk/atk.def: * atk/atk.symbols: * atk/atkhyperlink.h: * atk/atkobject.h: * docs/tmpl/atkhyperlink.sgml: * docs/tmpl/atkobject.sgml: Patch from Mike Gorse <mgorse@novell.com>. Bug #526752. Mark deprecated symbols with ATK_DISABLE_DEPRECATED. svn path=/trunk/; revision=1249
Diffstat (limited to 'atk/Makefile.am')
-rw-r--r--atk/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/atk/Makefile.am b/atk/Makefile.am
index 7bb3155..ab8c3be 100644
--- a/atk/Makefile.am
+++ b/atk/Makefile.am
@@ -11,6 +11,7 @@ endif
INCLUDES = \
-I$(top_srcdir) \
-DG_DISABLE_DEPRECATED \
+ -DATK_DISABLE_DEPRECATED \
-DATK_COMPILATION \
-DATK_LOCALEDIR="\"$(datadir)/locale\"" \
$(DEP_CFLAGS)
@@ -136,9 +137,13 @@ s-enum-types-c: @REBUILD@ $(atk_headers) Makefile
# ---------- Win32 stuff ----------
if OS_WIN32
+atk_def = atk.def
libatk_1_0_la_LDFLAGS += -export-symbols $(srcdir)/atk.def -no-undefined -Wl,atk-win32-res.o
libatk_1_0_la_DEPENDENCIES = atk-win32-res.o
+atk.def: atk.symbols
+ (echo -e EXPORTS; $(CPP) -P -DINCLUDE_VARIABLES -DG_OS_WIN32 -DALL_FILES - <$(srcdir)/atk.symbols | sed -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//g') > atk.def
+
install-def-file:
$(INSTALL) $(srcdir)/atk.def $(DESTDIR)$(libdir)/atk-1.0.def
uninstall-def-file: