summaryrefslogtreecommitdiff
path: root/spi-common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'spi-common/Makefile.am')
-rw-r--r--spi-common/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/spi-common/Makefile.am b/spi-common/Makefile.am
new file mode 100644
index 00000000..216c3789
--- /dev/null
+++ b/spi-common/Makefile.am
@@ -0,0 +1,20 @@
+noinst_LTLIBRARIES = libspicommon.la
+
+libspicommon_la_CFLAGS = $(DBUS_GLIB_CFLAGS) $(ATK_CFLAGS)\
+ -DATSPI_INTROSPECTION_PATH=\"$(DEFAULT_ATSPI_INTROSPECTION_PATH)\"\
+ -I$(top_builddir)\
+ -I$(top_srcdir)
+
+BUILT_SOURCES = generated-types.h
+CLEANFILES = generated-types.h
+
+nodist_libspicommon_la_SOURCES = generated-types.h
+
+libspicommon_la_SOURCES = \
+ event-types.h \
+ spi-types.h \
+ spi-dbus.h \
+ spi-dbus.c
+
+generated-types.h: $(top_srcdir)/xml/spec.xml $(top_srcdir)/tools/c-constants-generator.xsl
+ xsltproc --stringparam mixed-case-prefix Accessibility_ $(top_srcdir)/tools/c-constants-generator.xsl $< >$@