summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@gnome.org>2022-12-12 16:43:48 -0600
committerFederico Mena Quintero <federico@gnome.org>2022-12-12 16:47:54 -0600
commit7a0c7f420dca9793c5bb44e0406de3eb5d682284 (patch)
tree4bb4803c653775f221204145f184fd1323dac1d5 /meson.build
parentbd2417283454427570cc70623e90a924d03b46c4 (diff)
downloadat-spi2-core-7a0c7f420dca9793c5bb44e0406de3eb5d682284.tar.gz
Build the devel-docs as part of the meson build
Also, generate pages based on the documentation for the XML interfaces. It's easier to have this in meson, rather than an independent script, since now the final document depends on various things: the rst sources themselves, plus the rst docs extracted from the XML interface files.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1719a096..b386aa29 100644
--- a/meson.build
+++ b/meson.build
@@ -10,6 +10,8 @@ project('at-spi2-core', 'c',
add_project_arguments([ '-D_POSIX_C_SOURCE=200809L', '-D_DEFAULT_SOURCE' ], language: 'c')
+fs = import('fs')
+
atspi_gir_ns = 'Atspi'
cc = meson.get_compiler('c')