summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-10-15 12:44:39 -0700
committerTim Orling <ticotimo@gmail.com>2021-10-15 12:44:39 -0700
commit2175d89198440d948075f3268aec5f45430afb3d (patch)
treec00131c55591852ed83030199000c48b58b27490 /meson.build
parentb22b7dcfcb34f01218de0f6aa0d10b4d34fb07aa (diff)
downloadat-spi2-core-2175d89198440d948075f3268aec5f45430afb3d.tar.gz
Ensure x11_dep is defined
bus/meson.build checks if x11_dep.found(), but this fails when -Dx11=no References: https://gitlab.gnome.org/GNOME/at-spi2-core/-/issues/42 https://mesonbuild.com/howtox.html#get-a-default-notfound-dependency Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b5104c8c..cfd2e091 100644
--- a/meson.build
+++ b/meson.build
@@ -62,6 +62,8 @@ endif
x11_deps = []
x11_option = get_option('x11')
+# ensure x11_dep is defined for use elsewhere, such as bus/meson.build
+x11_dep = dependency('', required: false)
if x11_option != 'no'
x11_dep = dependency('x11', required: false)