summaryrefslogtreecommitdiff
path: root/bus/meson.build
diff options
context:
space:
mode:
authorMike Gorse <mgorse@alum.wpi.edu>2017-10-23 20:21:57 -0500
committerMike Gorse <mgorse@alum.wpi.edu>2017-10-23 20:21:57 -0500
commit70705839990f8eb5112b0262bb0960e806c62fbc (patch)
treed2fbada8a71c4e45fed460a8c520b335d7450013 /bus/meson.build
parent5811e35fedbdf7124872b6ffb76ae0bfa851bef2 (diff)
downloadat-spi2-core-70705839990f8eb5112b0262bb0960e806c62fbc.tar.gz
meson: x11 fixes
Meson wasn't defining HAVE_X11, so x11 support wasn't being compiled even if X was determined to be present. Also, add an enable-x11 option (default is to auto-detect).
Diffstat (limited to 'bus/meson.build')
-rw-r--r--bus/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/bus/meson.build b/bus/meson.build
index 8e4673f2..909103ce 100644
--- a/bus/meson.build
+++ b/bus/meson.build
@@ -45,7 +45,7 @@ endif
executable('at-spi-bus-launcher', 'at-spi-bus-launcher.c',
include_directories: [ root_inc, include_directories('.') ],
- dependencies: [ gio_dep ],
+ dependencies: [ gio_dep, x11_deps ],
c_args: [
'-DSYSCONFDIR="@0@"'.format(atspi_sysconfdir),
'-DDATADIR="@0@"'.format(atspi_datadir),