summaryrefslogtreecommitdiff
path: root/atspi/meson.build
diff options
context:
space:
mode:
authorMike Gorse <mgorse@suse.com>2021-01-11 13:32:06 -0600
committerMike Gorse <mgorse@suse.com>2021-01-11 13:32:06 -0600
commit7bd1ad706c92a9342e5078238ce4380e544aa967 (patch)
treef09ab765bb97dbcdd0cba047254768da7614eb02 /atspi/meson.build
parentbefced84236ec782d3a41d8cc06ceb3fdb61ae75 (diff)
downloadat-spi2-core-7bd1ad706c92a9342e5078238ce4380e544aa967.tar.gz
Add device API
This is intended to replace the registry-based method for capturing keystrokes. It is needed because gtk 4 no longer sends key notifications in a way that atk-bridge can process them. Unlike the original API, key grabs are separated from key notifications. Clients wishing to consume keystrokes must proactively register a grab for the given key. Currently, there is a backend for X11 and an unfinished legacy back end using the old registry-based method. Hopefully, there will be a mutter/wayland back end in the future, but we need to define a protocol there first.
Diffstat (limited to 'atspi/meson.build')
-rw-r--r--atspi/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/atspi/meson.build b/atspi/meson.build
index 5797f73a..a6f12384 100644
--- a/atspi/meson.build
+++ b/atspi/meson.build
@@ -4,6 +4,8 @@ atspi_sources = [
'atspi-application.c',
'atspi-collection.c',
'atspi-component.c',
+ 'atspi-device.c',
+ 'atspi-device-legacy.c',
'atspi-device-listener.c',
'atspi-document.c',
'atspi-editabletext.c',
@@ -26,6 +28,13 @@ atspi_sources = [
'atspi-value.c',
]
+x11_option = get_option('x11')
+if x11_option != 'no'
+ if x11_dep.found()
+ atspi_sources += ['atspi-device-x11.c']
+ endif
+endif
+
atspi_headers = [
'atspi.h',
'atspi-accessible.h',
@@ -34,7 +43,10 @@ atspi_headers = [
'atspi-collection.h',
'atspi-component.h',
'atspi-constants.h',
+ 'atspi-device.h',
+ 'atspi-device-legacy.h',
'atspi-device-listener.h',
+ 'atspi-device-x11.h',
'atspi-document.h',
'atspi-editabletext.h',
'atspi-event-listener.h',