summaryrefslogtreecommitdiff
path: root/atspi/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@gnome.org>2021-01-11 19:14:58 -0600
committerMichael Catanzaro <mcatanzaro@gnome.org>2021-01-11 19:18:39 -0600
commit5046d005e2048df6cfc16e60beaa27bb99d45f28 (patch)
treecbcedbcf49fb9e1ba5a275eb58476bbab44f7d3e /atspi/meson.build
parentb03b6a47af37fd1fa24c5ff604af643a84064898 (diff)
downloadat-spi2-core-5046d005e2048df6cfc16e60beaa27bb99d45f28.tar.gz
Fix build with X11 dep disabled
Diffstat (limited to 'atspi/meson.build')
-rw-r--r--atspi/meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/atspi/meson.build b/atspi/meson.build
index a6f12384..ace8502c 100644
--- a/atspi/meson.build
+++ b/atspi/meson.build
@@ -28,13 +28,6 @@ atspi_sources = [
'atspi-value.c',
]
-x11_option = get_option('x11')
-if x11_option != 'no'
- if x11_dep.found()
- atspi_sources += ['atspi-device-x11.c']
- endif
-endif
-
atspi_headers = [
'atspi.h',
'atspi-accessible.h',
@@ -46,7 +39,6 @@ atspi_headers = [
'atspi-device.h',
'atspi-device-legacy.h',
'atspi-device-listener.h',
- 'atspi-device-x11.h',
'atspi-document.h',
'atspi-editabletext.h',
'atspi-event-listener.h',
@@ -68,6 +60,14 @@ atspi_headers = [
'atspi-value.h',
]
+x11_option = get_option('x11')
+if x11_option != 'no'
+ if x11_dep.found()
+ atspi_sources += ['atspi-device-x11.c']
+ atspi_headers += ['atspi-device-x11.h']
+ endif
+endif
+
atspi_includedir = join_paths(get_option('prefix'), get_option('includedir'), 'at-spi-2.0', 'atspi')
install_headers(atspi_headers, install_dir: atspi_includedir)