summaryrefslogtreecommitdiff
path: root/atspi/meson.build
diff options
context:
space:
mode:
authorMike Gorse <mgorse@alum.wpi.edu>2019-07-18 18:21:09 -0500
committerMike Gorse <mgorse@alum.wpi.edu>2019-07-18 18:21:09 -0500
commit36a621aa17ed27be55cd9f16a1f7b29904cb510c (patch)
treeaab19c716716c0d831a3f180e88bddd6b9b60e90 /atspi/meson.build
parent5604b79d72179708b218ddaaf226fc38614ca4a9 (diff)
downloadat-spi2-core-36a621aa17ed27be55cd9f16a1f7b29904cb510c.tar.gz
Refactor the API for the screen reader to notify listeners of its status
Remove atspi_text_notify_reading_position, and instead add a region_changed signal. Also make the dbus API more like the API used for other events. Per discussion at https://gitlab.gnome.org/GNOME/orca/issues/36
Diffstat (limited to 'atspi/meson.build')
-rw-r--r--atspi/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/atspi/meson.build b/atspi/meson.build
index 2a6915d7..14c771b0 100644
--- a/atspi/meson.build
+++ b/atspi/meson.build
@@ -59,6 +59,13 @@ atspi_includedir = join_paths(get_option('prefix'), get_option('includedir'), 'a
install_headers(atspi_headers, install_dir: atspi_includedir)
+# Marshallers
+atspi_marshals = gnome.genmarshal('atspimarshal',
+ sources: 'atspimarshal.list',
+ prefix: 'atspi_marshal',
+)
+atspi_marshal_h = atspi_marshals[1]
+
atspi_enums = gnome.mkenums('atspi-enum-types',
sources: [ 'atspi-constants.h', 'atspi-types.h' ],
c_template: 'atspi-enum-types.c.template',
@@ -67,7 +74,7 @@ atspi_enums = gnome.mkenums('atspi-enum-types',
install_header: true)
atspi_enum_h = atspi_enums[1]
-atspi = library('atspi', atspi_sources + atspi_enums,
+atspi = library('atspi', atspi_sources + atspi_enums + atspi_marshals,
version: soversion,
soversion: soversion.split('.')[0],
include_directories: [ root_inc, registryd_inc ],