summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-04-27 11:47:44 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-05-17 15:02:03 +0100
commitb3c877c8d7ca25794a6ccd41b6cf99098204841b (patch)
tree9d4d5d9fb0249d4d63fd5f0102ffde071b0b6104 /meson.build
parent68678650984ae899f893bddbea82f9e6cca2f063 (diff)
downloadat-spi2-atk-b3c877c8d7ca25794a6ccd41b6cf99098204841b.tar.gz
build: Disable deprecation warnings in stable cycles
We know we're using deprecated API, so there's no real point in keeping the warnings. The deprecation warnings are useful during development cycles, so we can port away from deprecated API.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c6d0afd..8a0fbe0 100644
--- a/meson.build
+++ b/meson.build
@@ -17,6 +17,14 @@ host_system = host_machine.system()
# XXX: for strcasecmp(); should use g_ascii_strcasecmp()
add_project_arguments([ '-D_DEFAULT_SOURCE', ], language: 'c')
+# We are using deprecated API; don't warn if we're building stable
+# releases, to avoid making the build logs less readable. We keep
+# the warnings during development cycles, to remind us we should
+# port away from deprecated API
+if meson.project_version().split('.').get(1).to_int().is_even()
+ add_project_arguments([ '-DATK_DISABLE_DEPRECATION_WARNINGS' ], language: 'c')
+endif
+
# XXX: Unused
at_spi_conf = configuration_data()
at_spi_conf.set('GETTEXT_PACKAGE', meson.project_name())