summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-04-27 11:58:59 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-05-17 15:02:03 +0100
commita5e9828ca9d76a47b2783d4e6913ec35a657e304 (patch)
tree0231dd1b6ad595013b6c0b9e822ea6e626881eaf /meson.build
parent547d84228b3cf54c4d29d05ec23b03e9e02e9c24 (diff)
downloadat-spi2-atk-a5e9828ca9d76a47b2783d4e6913ec35a657e304.tar.gz
Generate the atk-bridge-2.0 pkg-config file
Instead of using a template, we can ask Meson to generate the file for us from the various build targets.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 0 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index 72b5b99..6928cbd 100644
--- a/meson.build
+++ b/meson.build
@@ -56,19 +56,6 @@ else
p2p_cflags = []
endif
-pkg_conf = configuration_data()
-pkg_conf.set('prefix', get_option('prefix'))
-pkg_conf.set('exec_prefix', get_option('prefix'))
-pkg_conf.set('libdir', join_paths(get_option('prefix'), get_option('libdir')))
-pkg_conf.set('includedir', join_paths(get_option('prefix'), get_option('includedir')))
-pkg_conf.set('VERSION', meson.project_version())
-
-configure_file(input: 'atk-bridge-2.0.pc.in',
- output: 'atk-bridge-2.0.pc',
- configuration: pkg_conf,
- install: true,
- install_dir: join_paths(get_option('libdir'), 'pkgconfig'))
-
install_data('at-spi2-atk.desktop',
install_dir: join_paths(get_option('libdir'), 'gnome-settings-daemon-3.0', 'gtk-modules'))