summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2005-05-13 14:44:21 +0000
committerJoe Orton <jorton@apache.org>2005-05-13 14:44:21 +0000
commita6e3e8896830f86ce175e7729c2caf200fdd90eb (patch)
tree03d73eff301397a3ce206f07a756c16b7a55f349 /configure.in
parentb11927779176c8c296f1f56f5b24f4b8651d97b8 (diff)
downloadhttpd-a6e3e8896830f86ce175e7729c2caf200fdd90eb.tar.gz
* configure.in: Disallow use of bundled APR with external APR-util, or
bundled APR-util with external APR, another cause of the dreaded PR21718. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@170029 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 422d59d747..c7e43e9a32 100644
--- a/configure.in
+++ b/configure.in
@@ -95,6 +95,16 @@ if test "$apu_found" = "no"; then
AC_MSG_ERROR([APR-util not found. Please read the documentation.])
fi
+# Catch some misconfigurations:
+case ${apr_found}.${apu_found} in
+reconfig.yes)
+ AC_MSG_ERROR([Cannot use an external APR-util with the bundled APR])
+ ;;
+yes.reconfig)
+ AC_MSG_ERROR([Cannot use an external APR with the bundled APR-util])
+ ;;
+esac
+
if test "$apu_found" = "reconfig"; then
APR_SUBDIR_CONFIG(srclib/apr-util,
[--with-apr=../apr --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir],