summaryrefslogtreecommitdiff
path: root/depgraph/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'depgraph/Makefile.am')
-rw-r--r--depgraph/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/depgraph/Makefile.am b/depgraph/Makefile.am
new file mode 100644
index 0000000..94e75b4
--- /dev/null
+++ b/depgraph/Makefile.am
@@ -0,0 +1,19 @@
+# Files
+DEPWORDS = master.depword noun.depword v.depword \
+ av.depword a.depword\
+ ajv.depword noun-variant.depword \
+ fix.depword conjugate.depword \
+ conjugate.table
+INCLUDES = -I$(top_srcdir)/ -DSRCDIR=\"$(srcdir)\"
+CLEANFILES = anthy.dep
+EXTRA_DIST = indepword.txt $(DEPWORDS)
+
+# Generate the dictionary
+noinst_PROGRAMS = mkdepgraph
+mkdepgraph_SOURCES = mkdepgraph.c
+mkdepgraph_LDADD = ../src-main/libanthy.la ../src-worddic/libanthydic.la
+
+anthy.dep : mkdepgraph $(DEPWORDS)
+ ./mkdepgraph
+
+noinst_DATA = anthy.dep